PDA

View Full Version : MusicIndiaOnline in Firefox (Linux)



emyesbee
12-02-2005, 10:38 PM
Hi

Can anybody using linux and firefox open the tridentplayer of Music India Online? I am not able to run it either in firefox or in mozilla. I have installed realplayer 10.0.6 and have installed the plugins also when I open some song in MIO the trident player of MIO comes up it recognizes realplayer as available but it does not run at all. It just says loading....that is it. Can anybody help............ I was actually using it without any problem when I was using ol version of firefox if iam not wrong 0.9.

Bye
Sakthi

Narayana
12-03-2005, 03:38 AM
not working 4 me...
I think it used to work until i upgraded to real 10. Then i started getting some realplay not in the path or something like that... but realplay is in the system path...

emyesbee
12-03-2005, 01:02 PM
For me it was working even when I had real10 but with older version of firefox. But after I installed the new version of firefox its not working. It is finding the realpalyer but it says loading wait.......nohting else :(

I think so problem with MIO site. Probably I have to mail them and inform this.

ns80
12-05-2005, 02:54 AM
Even I don't Musicindiaonline player working. Streaming in Raaga works for me though. I have the latest version of Realplayer installed in my system.

emyesbee
12-05-2005, 11:03 AM
even for raaga it is not working i do not know why

ns80
12-05-2005, 04:15 PM
Do you use Firefox 1.5 or 1.0.7. Does'nt work in 1.5 for me. For 1.0.7, apart from symlinks to nphelix.so and nphelix.xpt in .mozilla/plugins you should add a symlink to realplay in the home directory. Thats how it worked for me in 1.0.7. Even Oosai.com does'nt work for me :?, only Raaga works.

emyesbee
12-05-2005, 04:17 PM
Can u expalin a bit more abt inclusing a sym link to realplay?

Thank you

ns80
12-05-2005, 04:28 PM
There will be 2 files, nphelix.xpt and nphelix.so in the mozilla directory where you have realplayer installed. I am using Helix player. This is how my .mozilla/plugins looks after symlinking


narayanan@ranganathanstreet:~/.mozilla/plugins$ ls -l
total 2056
-rw-r--r-- 1 narayanan narayanan 856 2004-05-20 14:34 flashplayer.xpt
-rwxr-xr-x 1 narayanan narayanan 2096844 2004-05-20 14:34 libflashplayer.so
lrwxrwxrwx 1 narayanan narayanan 57 2005-12-04 23:47 libjavaplugin_oji.so -> /usr/lib/j2re1.5-sun/plugin/i386/ns7/libjavaplugin_oji.so
lrwxrwxrwx 1 narayanan narayanan 35 2005-12-04 23:46 nphelix.so -> /opt/HelixPlayer/mozilla/nphelix.so
lrwxrwxrwx 1 narayanan narayanan 36 2005-12-04 23:46 nphelix.xpt -> /opt/HelixPlayer/mozilla/nphelix.xpt

and in your home directory, just create a path to realplay, someting like this:


narayanan@ranganathanstreet:~$ whereis realplay
realplay: /usr/bin/realplay /usr/bin/X11/realplay
narayanan@ranganathanstreet:~$ ls -l r*
lrwxrwxrwx 1 narayanan narayanan 21 2005-12-04 21:46 realplay -> /usr/bin/X11/realplay

When you install Firefox 1.5 it clears out the plugin directory, so you have to do this all over again. It does'nt work anyway is another issue :ee:

krishng
12-05-2005, 04:33 PM
it happened to me before in windows that is when i updated my real player, all streaming radio doesnt work. then i have completely removed the real player from my system and freshly download the player and installed it. now its working fine. so u can try this case here in linux..

this is just my experience.
cheers.

ns80
12-09-2005, 05:14 PM
Does Firefox 1.0.7 crash for you when you load a forum page with embedded media :think: Noticed this happening quite a few times for me, especially when replying a thread, not even while loading the thread.

emyesbee
12-09-2005, 07:04 PM
You mean multimedia files? I have not still isntalled mplayer/xine and plugins to get them in firefox. But iam not at all happy with this version. That is why I got irritated and do not want to continue installing any more plugins in this cribbled version of firefox. I shoukld have just installed the older one which was very stable and in which all the plugins were working really good.

emyesbee
12-09-2005, 07:09 PM
krish

My browser knows that I have installed realplayer suitable plugin files are there and even Ic an play Geetham radio in realplayer using my plugin in my firefox. So there is no problem with that. Perhaps some configuration problem in realplayer; we have to change some configuration to suit the trident player of MIO. But I tried to my knowledge all combinations but still no use :(

When I press play button in MIO I can see that trident player sees my realplayer and it opens the player but after that it just says loading nohting else. It just stays there; it is not hanging also; it just says loading....wait. I ma still waiting :)

ns80
12-09-2005, 07:14 PM
Shakthi,
which Firefox version worked fine for you? Yeah 1.0.7 that comes bundled with Ubuntu sucks big time, crashes umpteen times. Firefox 1.5 was much stable. But Tamil fonts looked wierd.
~~~~~~
I have the same problem with MIO :(
~~~~~~
One bad thing about reinstalling Firefox is that it'll clean up the .mozilla/plugins directory :?

emyesbee
12-09-2005, 07:23 PM
I am using firefox 1.0.7. I installed it through yum. I have emailed MIO abt this. Hope to get it solved let us see. :)

Narayana
12-10-2005, 02:08 AM
Narayan,
do you have HT enabled processor? Firefox crashes in that when u open multiple tabs in geetham... I updated my bio and its ok now... I'm happy with firefox1.0.7 in mandriva. so am using 1.5 in win and 1.0.7 in linux

ns80
12-10-2005, 04:17 AM
do you have HT enabled processor?

appadina ennanu puriyaliye :think:

Narayana
12-10-2005, 06:10 AM
i meant hyperthreading.. the OS will see two logical processors even though there is only one physical processor. If you check your BIOS you will know. or press the famous ctrl-Alt-Del in Windows and in the performance tab, there will be two parts for cpu usage history. one for each logical processor.
cheers.

ns80
12-10-2005, 04:26 PM
Narayana, I see only one part in CPU usage :( not 2 :?.

ns80
12-14-2005, 02:54 AM
Anyone played around with Wine (http://winehq.com/) :think: i was browsing through the Ubuntuforums when this thread on IE via Wine (http://ubuntuforums.org/showthread.php?t=103238) caught my eye :D would that mean all the plugins would work :think:

Narayana
12-14-2005, 06:08 AM
hehe now firefox 1.0.7 is also crashing in linux. nice. happy.

emyesbee
12-18-2005, 04:47 PM
I got a simple round about of playing MIO files using realplay from one of my friend.

realplay http://www.musicindiaonline.com/g/r/`echo $1 | tr / '\n' | grep [a-z] | tail -1`/play.smil

Type the above link in an executable file and then open this file with the proper link of the song which you want to play in MIO as an argument to this file.

I think we can try it out for a playlist also. If i succeed I will inform you :)

Bye
Sakthi

emyesbee
12-18-2005, 04:48 PM
Sorry the line "Type the above link...." should be "Type the above command...."

emyesbee
12-25-2005, 03:24 AM
I have written a simple script to automatically get the playlist of a particular artist from MIO, which we can use to play streaming songs from MIO in our realplay instead of using MIO tridnet player. If anyone needs it please drop me a message.

Narayana
12-27-2005, 04:05 AM
that MIO hack is really good...
i'll try to write a script on my own... ( i am yet to write my first script :ee: )
let me try...

ns80
01-12-2006, 10:23 PM
I installed IE on Linux yesterday :ee: Try the installer (http://sidenet.ddo.jp/winetips/config.html) from that page. Just install the latest version of wine before using the installer. The installer worked fine, might be we can try MIO through that :think: I'll try it today.
~~~~~~
MSB can you PM the script you used for playing MIO files in Linux.

emyesbee
01-20-2006, 08:27 PM
Hi NS

I totally forgot to message you the script. Sirry i will do that by tonite.

By the way I just installed SUSE 9.3 Pro in my office desktop. Oh my GOD!! it went without any problem. So fine everything automatically detected. It was just like put CD and forget about it. I love SUSE now. So far so good.....let me see how it performs......may be if this is better I would try the installtuion in my latop replacing Fedora core 4. Only thing my laptop with FC4 gives problem is the suspend mode not working. I tried all kinds of method. SUSE has laptop modes and suspend modes together with the OS package. I think it should work.

MusicIndiaonline works in SUSE firefox :) I do not even want to install realplay it came with the package.

And few days back I got to know my MIO does not work, see this webiste:

http://www.cs.cornell.edu/~scs49/install_linux.html#destHeader1 64

But I have spent so much time in trying out and I do not want to waste time again for this stuff :)

sakthi

Narayana
01-21-2006, 10:20 AM
i think MIO have changed from p/x to p/xx ??


By the way I just installed SUSE 9.3 Pro in my office desktop
You could have tried Suse 10. I'm downloading the dvd iso image.. will install next week :ee:
I'm also planning to try to compile kernel from source. :Ksp: :pray: :pray:

emyesbee
01-21-2006, 12:37 PM
I have SUSE10 DVD but there is no DVDROM; I had external DVDRW drive but it was of no use. Hence had to do SUSE9.3 with CD. I will try SUSE10 in my laptop :)

emyesbee
01-25-2006, 06:03 PM
I think I have to take back the words which I said about SUSE :(

First day my CDRW and external DVDRW worked. But after that no :(

It has recognized the drives but it could not mount it properly. When I mount the CD it gives no errors but when I want to list the files it says no medium found :( Then I came upon this page saying there is a serious bug in SUSE :( I tried updating installing again and again bu the same problem. All the drives were working fine with WinXP. And that too with the same internal drive CDRW I installed the SUSE 9.3 but after installing SUSE it is not working. Hence I think it is bug in SUSE 9.3 too :( see this.....

http://www.acaciaclose.co.uk/37529/?*session*id*key*=*session*id* val*

I can try to do this but since I had fedaora core 4 CDs I installed now itse working fine after some small problems :) But quite suprprised with SUSE with these basic problems like CD mounting

emyesbee
01-25-2006, 06:04 PM
Hi NS

I have pm'ed the perl script to you for MIO :)

Enjoy!!

emyesbee
01-27-2006, 07:43 PM
NS

did u get the script?

I installed fedora core 4 in my office desktop and wine 0.9.2-1 too :) ie and wmp working. But I do not know how to make mio tridetn palyer to work. iam not able to install java.

I do not know how :( iam still searching it

yogesh220
01-27-2006, 11:24 PM
do not know how iam still searching it

good luck in finding.....

ns80
01-27-2006, 11:35 PM
Shakti,
I got the script, dint get a chance to try that though. adhaan innum post pannale.

If you visit a site thro IE on Linux (using wine), the browser and platform is detected as Internet Explorer - Windows 98 and does'nt show up as Linux. If am right, IE on Linux requires a package called fake-windows to install it. Am clueless how to make a plugin to work on that :Ksp:

Not able to install java :think: what error do you get ?

emyesbee
01-27-2006, 11:36 PM
I think it is waste of time :( MIOla play panna mudiyala athukuthan entha koothu paneetu erukaen..ellati ethukku entha windowsuuu :)

emyesbee
01-27-2006, 11:39 PM
NS i have installed the wine and its configurations for IE and WMP using the webiste you gave so it is working now.

When I try to install the JDK .exe file nothiong happens in my system :( I do not know what is happening so got irritated and came home :( I have to try on Monday if I ahve time for that

Narayana
01-28-2006, 01:35 PM
i took broadband and no other problems, just no internet in linux... :(
i'm going to format and compile linux.... :pray: :pray: