PDA

View Full Version : xmms for Linux.... (this is a audio player btw...)



sweetie
10-09-2003, 06:20 AM
Hi People

The RHL 8 and 9 seems to be shipped without the mp3 plugins, obviously due to some patent problems.....

So here are some files built exclusively on the redhat package...

6FACE..... Is xmms working as normal after u upgraded to RHL 9 ??? If not check this out.. just install the rpms... thats all u need to do...

http://havardk.xmms.org/dist/xmms-1.2.7-rh8-rh9-rpm/xmms-1.2.7-21.i386.rpm
http://havardk.xmms.org/dist/xmms-1.2.7-rh8-rh9-rpm/xmms-mpg123-1.2.7-21.i386.rpm
http://havardk.xmms.org/dist/xmms-1.2.7-rh8-rh9-rpm/xmms-skins-1.2.7-21.i386.rpm
http://havardk.xmms.org/dist/xmms-1.2.7-rh8-rh9-rpm/xmms-devel-1.2.7-21.i386.rpm

Source -- http://havardk.xmms.org/dist/xmms-1.2.7-rh8-rh9-rpm/xmms-1.2.7-21.src.rpm

This info courtesy of

http://havardk.xmms.org/dist/xmms-1.2.7-rh8-rh9-rpm/xmms-devel-1.2.7-21.i386.rpm

and

http://yolinux.com/TUTORIALS/LinuxTutorialRedHatInstallatio n.html

Cheers....

arumugam57
10-09-2003, 06:27 AM
I am having great problem in installing src.rpm files. So many times I installed so many src.rpm files. but still confusion exists.

Tell the procedure in deatail. How to install one src.rpm file?

In the above links if I able to install source src.rpm file then I need not install all other files right? Like skin , devel files.

sweetie
10-09-2003, 07:42 AM
Nope 6FACE .... the source is available coz this is a free s/w.... under a public license... when u install a source rpm, it will not work out of the box... U *have* to compile it... I guess u wud'nt want to do that... I gave the source file coz it was available there...

Just get the other rpm's and install them.... if U have ne dependency problems, try doing

$ rpm -i --nodeps < file name >

Dear 6FACE..... Use the Linux vast man pages dude.....

$ man rpm

And u've got so many other man pages ... check them out....

arumugam57
10-09-2003, 08:57 AM
I know how to compile source file having all C/C++ codes. I did it while installing Xv in my computer.

But you see this src.rpm is totally different.
For example once i tried

rpm -Urh file.src.rpm
then I went and have seen a rpm file at /usr/src/redhat/RPMS/i386/file.rpm

then i did
rpm -i /usr/src/redhat/RPMS/i386/file.rpm

and it worked.
---------------------------

And in more application I did


rpm -rebuild file.src.rpm
then I went and have seen a rpm file at /usr/src/redhat/RPMS/i386/file.rpm

then i did
rpm -i /usr/src/redhat/RPMS/i386/file.rpm
---------------------------------------------------

And some of the src.rpm files are not getting compiled/installed using above commands.

Any idea?

sweetie
10-09-2003, 09:04 AM
try using the -F or -f option ..... that is for freshen....

Do not upgrade ur existing xmms player.... some files in RHL 9 dusnt seem to go thru the upgrade... rather freshen it up and u shud see wat u want I guess....

N moreover when u r installing a src file, look for where a file / dir is created.... n then go to that directory and compile it first... without compiling the source file u cant install it....

but I cant see why u r hell bent on wanting to use the source... When U have the other essential files, which U just need to install rightaway n start using them....

And r u doing it as root ????

arumugam57
10-09-2003, 12:18 PM
Yes I am root.

See source files are universal.
RPMs we can not install if some problems like dependencies comes.

Still I could not get correct answer from you.
--------------------------------------------------------
Ok simple question.
U are having gaim.src.rpm to install gaim ( a messenger service).
what are the commands you do. Just tell me that. Thats it.

sweetie
10-09-2003, 02:29 PM
First of all did U *try* installing the rpm's ???

Yes... thats why I said if U get ne dependency problems, use

$ rpm -i --nodeps < file name>

Did U do or try that ???

I did not have to install nething specifically in my comp..... When I installed Linux everything was custom installed.... So I din care to look at the source files .... and moreover I am not pro in compiling n stuff..... So I din touch that... rather, if needed I wud have done... since, as I said before, everything was custom installed, gaim works for me out of the box....

sweetie
10-09-2003, 02:36 PM
try doing this...

Place the file you downloaded in the /usr/src directory. You must be root to do this.

if the file is in bzip format, do this....

bunzip2 <file name>

If the file is in gzip format, do this....

gunzip <file name>

Since u have a rpm file, just do as u wud normally....

rpm -i <file name>

You should now have a file named xmms.....rpm (example... check out what the real file is called as)

Before you install the rpm file, you should be aware that this xmms will install itself... If you have other xmms (prev one) already installed, you should *remove it first* ....

rm xmms

(or try doing rpm -e <file name> where just xmms shud work if its already installed.... or something similar....)

then install the rpm file....

rpm -i <file name>

After u installed, make sure the file is placed in /usr/bin coz thats where the invokable commands are placed.... and u shud be done with this I guess.....

Please get back as to what happened with a feedback.... thanks...